15
ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ OPMH κοντά στο μαθητή! ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh email: [email protected] ~ 1 ~ forum: http://ormimath1.comule.com 3ο Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης 1. Το παραγοντικό Ν! ορίζεται ως εξής: 1 , 0 ! 1*2*3*...* , 0 . Να γραφεί αλγόριθμος ο οποίος θα διαβάζει έναν μη αρνητικό ακέραιο αριθμό Ν (με έλεγχο εγκυρότητας) και θα υπολογίζει το παραγοντικό. 2. Για τις ανάγκες μιας τηλεοπτικής αθλητικής εκπομπής επιλέχτηκε ένας επιθετικός από κάθε μία από τις 18 ομάδες που συμμετείχαν πέρυσι στην Super league. Να αναπτύξετε αλγόριθμο ο οποίος θα διαβάζει τον αριθμό των τερμάτων που πέτυχαν κάθε ένας από τους ποδοσφαιριστές και θα υπολογίζει και να εμφανίζει: I. το άθροισµα των τερµάτων, II. το µέσο όρο των τερµάτων, III. το πλήθος των ποδοσφαιριστών που πέτυχαν περισσότερα από 10 τέρµατα IV. και τα τέρµατα που πέτυχε ο πρώτος σκόρερ. 3. Να γραφεί αλγόριθμος ο οποίος θα διαβάζει έναν θετικό ακέραιο αριθμό Ν (με έλεγχο εγκυρότητας) και θα υπολογίζει το άθροισμα 2 4 8 16 2 3 9 3 1 , : 2 , : 4 2 N N N ά s ό 4. Να γραφεί αλγόριθμος που θα εκτυπώνει τις ακέραιες λύσεις της εξίσωσης: 2 3 10 x y με , 20, 20 xy . 5. Να γραφεί αλγόριθμος ο οποίος θα βρίσκει και θα εκτυπώνει τους πενταψήφιους αριθμούς που μπορούν να διαβαστούν και ανάποδα. (Π.χ 78387, 14641 55555) 6. Να γραφεί πρόγραμμα που θα διαβάζει θετικό ακέραιο αριθμό ( με έλεγχο εισαγωγής δεδομένων) και θα εκτυπώνει το πλήθος των ψηφίων του. Κατόπιν να γίνει το διάγραμμα ροής του παραπάνω προγράμματος. 7. Να γραφεί πρόγραμμα που να διαβάζει τους πόντους ενός καλαθοσφαιριστή σε κάθε αγώνα και να υπολογίζει σε πόσους αγώνες έχει πετύχει διψήφιο αριθµό πόντων. Το πρόγραμμα να τερµατίζεται όταν δοθεί ως είσοδος ένας αρνητικός αριθµός ή ένας αριθµός μεγαλύτερος του 200. (Να γίνει έλεγχος ορθότητας δεδομένων).

3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

Embed Size (px)

Citation preview

Page 1: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 1 ~ forum: http://ormimath1.comule.com

3ο Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης

1. Το παραγοντικό Ν! ορίζεται ως εξής: 1 , 0

!1*2*3*...* , 0

. Να γραφεί αλγόριθμος

ο οποίος θα διαβάζει έναν μη αρνητικό ακέραιο αριθμό Ν (με έλεγχο εγκυρότητας) και θα υπολογίζει το παραγοντικό.

2. Για τις ανάγκες μιας τηλεοπτικής αθλητικής εκπομπής επιλέχτηκε ένας επιθετικός από κάθε μία από τις 18 ομάδες που συμμετείχαν πέρυσι στην Super league. Να αναπτύξετε αλγόριθμο ο οποίος θα διαβάζει τον αριθμό των τερμάτων που πέτυχαν κάθε ένας από τους ποδοσφαιριστές και θα υπολογίζει και να εμφανίζει:

I. το άθροισµα των τερµάτων, II. το µέσο όρο των τερµάτων, III. το πλήθος των ποδοσφαιριστών που πέτυχαν περισσότερα από 10 τέρµατα IV. και τα τέρµατα που πέτυχε ο πρώτος σκόρερ.

3. Να γραφεί αλγόριθμος ο οποίος θα διαβάζει έναν θετικό ακέραιο αριθμό Ν (με έλεγχο

εγκυρότητας) και θα υπολογίζει το άθροισμα

2 4 8 16 2

3 9 31 , :

2

, :

4 2

N

N

N

ά

s ό

4. Να γραφεί αλγόριθμος που θα εκτυπώνει τις ακέραιες λύσεις της εξίσωσης: 2 3 10 x y με

, 20,20 x y .

5. Να γραφεί αλγόριθμος ο οποίος θα βρίσκει και θα εκτυπώνει τους πενταψήφιους αριθμούς που μπορούν να διαβαστούν και ανάποδα. (Π.χ 78387, 14641 55555)

6. Να γραφεί πρόγραμμα που θα διαβάζει θετικό ακέραιο αριθμό ( με έλεγχο εισαγωγής δεδομένων) και θα εκτυπώνει το πλήθος των ψηφίων του. Κατόπιν να γίνει το διάγραμμα ροής του παραπάνω προγράμματος.

7. Να γραφεί πρόγραμμα που να διαβάζει τους πόντους ενός καλαθοσφαιριστή σε κάθε αγώνα και να υπολογίζει σε πόσους αγώνες έχει πετύχει διψήφιο αριθµό πόντων. Το πρόγραμμα να τερµατίζεται όταν δοθεί ως είσοδος ένας αρνητικός αριθµός ή ένας αριθµός μεγαλύτερος του 200. (Να γίνει έλεγχος ορθότητας δεδομένων).

Page 2: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 2 ~ forum: http://ormimath1.comule.com

8. Σε µια εταιρεία παρκινγκ υπάρχουν 3 χώροι στάθμευσης ανάλογα µε το είδος των οχηµάτων που σταθμεύουν (φορτηγά, Ι.Χ. και μοτοσικλέτες). Για κάθε όχηµα κόβεται ένα εισιτήριο. Στο παρκινγκ συνολικά μπορούν να κοπούν μέχρι 450 εισιτήρια την ηµέρα, ανεξαρτήτως του είδους των οχηµάτων. Γράψτε πρόγραμμα το οποίο:

i. θα διαβάζει το είδος του οχήµατος (Φ) για φορτηγά, (Ε) για τα Ι.Χ. και (Μ) για μοτοσικλέτες.(Να γίνεται έλεγχος εγκυρότητας δεοδομένων)

ii. θα υπολογίζει τον αριθµό των φορτηγών, των Ι.Χ. και των μοτοσικλετών που πάρκαραν στο τέλος της ηµέρας.

Σημείωση: Το πρόγραμμα θα τερματίζει όταν σαν είσοδος δοθεί «τέλος»

9. Το μέσο ημερήσιο κόστος νοσηλείας στα ελληνικά νοσοκομεία είναι 93 €. Να γραφεί αλγόριθμος ο οποίος θα υλοποιεί τα εξής:

i. Θα διαβάζει το πλήθος των ασθενών σε ένα νοσοκομείο. Ο αριθμός των ασθενών δεν μπορεί να είναι μικρότερος από 10 και μεγαλύτερος από 500.

ii. Θα διαβάζει για κάθε ασθενή, τις ημέρες νοσηλείας και το είδος του ασφαλιστικού του φορέα (Ο) για Ο.Α.Ε.Ε , (Ι) για το ΙΚΑ, (Α) για άλλο ασφαλιστικό φορέα και (ΑΝΑ) αν είναι ανασφάλιστος.

iii. Θα υπολογίζει και θα εμφανίζει το συνολικό αριθμό των ασθενών που ήταν ασφαλισμένοι στο ΙΚΑ

iv. Το συνολικό ποσό των χρημάτων που κόστισαν όλοι οι ασθενείς v. Το μέσο όρο ημερών νοσηλείας vi. Το μέγιστο αριθμό ημερών νοσηλείας

10. Το αμφιθέατρο ενός θεάτρου έχει 50 καθίσματα στην πρώτη σειρά και σε κάθε επόμενη

από τις 15 συνολικά σειρές αυξάνονται τα καθίσματα κατά 10%. Να αναπτύξετε αλγόριθμο ο οποίος να υπολογίζει και να εκτυπώνει τα καθίσματα της τελευταίας σειράς καθώς και την χωρητικότητα του θεάτρου.

11. Η Π.Α.Ε. Παναχαϊκή αποφάσισε να τοποθετήσει νέα καθίσματα σε μια κερκίδα στο γήπεδο της Αγυιάς. Το κόστος κάθε καθίσματος είναι 45 € ενώ για το έργο έχει προϋπολογισμό 25.000 €. Στην πρώτη σειρά τοποθετούνται 50 καθίσματα και σε κάθε επόμενη 6 καθίσματα επιπλέον την προηγούμενης σειράς. Να γραφεί αλγόριθμος που να υπολογίζει τον αριθμό των καθισμάτων που μπορούν να τοποθετηθούν και το ποσό των χρημάτων που θα περισσέψουν.

12. Σε κάποιες εκλογές κατέβηκαν 4 κόμματα. Τα εκλογικά τμήματα της χώρας είναι 1500. Να γραφεί αλγόριθμος ο οποίος:

I. Διαβάζει για κάθε εκλογικό τμήμα τις ψήφους που πήρε κάθε κόμμα. II. Υπολογίζει τις συνολικές ψήφους κάθε κόμματος

III. Υπολογίζει και εμφανίζει τα ποσοστά κάθε κόμματος με την υπόθεση ότι δεν υπήρχαν άκυρα και λευκά ψηφοδέλτια.

Page 3: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 3 ~ forum: http://ormimath1.comule.com

13. Για 150 μαθητές/τριες της Γ΄ τάξης ενός λυκείου δίνονται το όνομα τους, το φύλο τους (Α ή Γ) και ο βαθμός πρόσβασής τους. Να γραφεί αλγόριθμος ο οποίος:

I. Διαβάζει για κάθε μαθητή τα παραπάνω δεδομένα ελέγχοντας την ορθή καταχώρηση του φύλου και του βαθμού (1-20)

II. Βρίσκει και εμφανίζει το μαθητή (όνομα) με το μεγαλύτερο βαθμό. III. Βρίσκει και εμφανίζει τη μαθήτρια (όνομα) με το μικρότερο βαθμό. IV. Βρίσκει και εμφανίζει το μέσο όρο των αριστούχων μαθητών και μαθητριών (από 18.5

και πάνω). V. Βρίσκει και εμφανίζει πόσοι μαθητές είχαν βαθμό πρόσβασης κάτω από 10.

14. Ένα videoclub νοικιάζει στους πελάτες του ταινίες τύπου Blu-ray (κωδικός = 1) και ταινίες σε DVD (κωδικός=2). Η ελάχιστη χρέωση για κάθε ταινία Blu-ray είναι 3,5 € και για κάθε DVD 2,5 € και ο μέγιστος χρόνος που μπορεί να κρατήσει ο πελάτης ένα Blu-ray είναι 4 ημέρες, ενώ ένα DVD 3 ημέρες, χωρίς να χρεωθεί με επιπλέον ποσό. Η καθυστέρηση χρεώνεται με 1,8 € για κάθε Blu-ray και με 1,.5 € για κάθε DVD για κάθε ημέρα καθυστέρησης. Να γραφεί αλγόριθμος που να υλοποιεί τα εξής:

I. Να διαβάζει τα στοιχεία 20 ενοικιάσεων πελατών (ονοματεπώνυμο πελάτη, κωδικός ταινίας (1 ή 2), ημέρες παρακράτησης) Με έλεγχο εισαγωγής δεδομένων για τον κωδικό και για τις ημέρες παρακράτησης.

II. Να υπολογίζει και να εκτυπώνει την αναλυτική χρέωση ανά πελάτη III. Να υπολογίζει και να εκτυπώνει τη συνολική χρέωση όλων των πελατών IV. Να υπολογίζει και να εκτυπώνει το μέσο όρος χρέωση ανά είδος ταινίας.

15. Ο υδροφόρος ορίζοντας του δήμου Ερμιονίδος εξαντλείται. Το δημοτικό συμβούλιο αποφάσισε να πραγματοποιήσει νέα γεώτρηση για την υδροδότηση του δήμου. Τα πάγια έξοδα για την πληρωμή του συνεργείου είναι 3000 € και περιλαμβάνεται το κόστος για πρώτα 100 μέτρα. Το μέτρο 101 κοστίζει 0.80 € και για κάθε μέτρο γεώτρησης το κόστος αυξάνεται κατά 1.25%. Ωστόσο, σύμφωνα με στατιστικές μελέτες στην περιοχή της γεώτρησης δείχνουν πως αν δεν βρεθεί ικανή ποσότητα νερού σε βάθος 550 μέτρων δεν έχει νόημα να προχωρήσει η εργασία. Να αναπτυχθεί αλγόριθμος όπου:

i. θα υπολογίζει και θα εκτυπώνει το κόστος της γεώτρηση για βάθος 550 μέτρα

ii. θα διαβάζει τα το διαθέσιμο για την γεώτρηση ποσό και να εκτυπώνει το μέγιστο βάθος

που η γεώτρηση μπορεί να φτάσει.

Page 4: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 4 ~ forum: http://ormimath1.comule.com

16. Να αναπτυχθεί αλγόριθμος που θα διαβάζει το επιτρεπόμενο βάρος ενός ferry boat και στη συνέχεια επαναληπτικά το βάρος του οχήματος που πρόκειται να εισέλθει σε αυτό καθώς και τον τύπο του ("Φ" για φορτηγό, "Α" για αυτοκίνητο και "Μ" για μοτοσικλέτα) μέχρι να μη παραβιαστεί ο περιορισμό του συνολικού βάρους. Αν το κόστος μεταφορά είναι 5.50 € για ένα φορτηγό, 3.40 για ένα αυτοκίνητο και 1.25 για μια μοτοσικλέτα ο αλγόριθμος να εκτυπώνει τα έσοδα του ferry boat για τη συγκεκριμένη μεταφορά, και τον μέγιστο αριθμό συνεχόμενων φορτηγών που επιβιβάστηκαν . 17. Να μεταφέρετε το παρακάτω διάγραμμα ροής σε μορφή ψευδοκώδικα.

18. Να σχηματίσετε το διάγραμμα ροής για τον παρακάτω αλγόριθμο.

Αλγόριθμος Μετατροπή1 μετρητής ← 0 άθροισμα ← 0 Αρχή_Επανάληψης Διάβασε αριθμός μετρητής ← μετρητής + 1 άθροισμα ← άθροισμα + αριθμός ^ 2 Μέχρις_Ότου (μετρητής = 100) Αν (μετρητής <> 0) τότε μέσος_όρος ← άθροισμα / μετρητής Εμφάνισε άθροισμα, μέσος_όρος Αλλιώς Εμφάνισε "Κανείς αριθμός" Τέλος_Αν Τέλος Μετατροπή1

Page 5: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 5 ~ forum: http://ormimath1.comule.com

19. Να μετατρέψετε το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τις άλλες δυο δομές επανάληψης και να σχηματίσετε το διάγραμμα ροής.

α ← 2 β ← 3 Αρχή_Επανάληψης Εκτύπωσε β β ← β + 2 Μέχρις_Ότου (β > 11) 20. Να αναπαραστήσετε τον αλγόριθμο που αντιστοιχεί στο παρακάτω διάγραμμα ροής και να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου για τιμές εισόδου 3,10,15,5,2. Τι θα εκτυπωθεί τελικά;

21. Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τι θα εκτυπωθεί ;

Αλγόριθμος Πίνακας_Τιμών β ← 0 Για i από 1 μέχρι 3 α ← 2 * i Για j από i μέχρι α β ← β + i * j Τέλος_Επανάληψης Εμφάνισε β Τέλος_Επανάληψης Τέλος Πίνακας_Τιμών

Page 6: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 6 ~ forum: http://ormimath1.comule.com

22. Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τι θα εκτυπωθεί ; Να σχηματίσετε και το διάγραμμα ροής.

Αλγόριθμος Πίνακας_Τιμών β ← 3 τ ← 0 Για i από 1 μέχρι 4 β ← β + 2 Για j από β μέχρι i με_βήμα -2 τ ← τ + j Τέλος_Επανάληψης Εμφάνισε τ, β Τέλος_Επανάληψης Τέλος Πίνακας_Τιμών 23. Να συμπληρώσετε τα κενά στον παρακάτω αλγόριθμο ώστε να εμφανίζονται οι αριθμοί:

-1, 2, -3, 4, -5, 6, -7. Αλγόριθμος Συμπλήρωση_κενών Για i από ___ μέχρι ____ Αν _______________ τότε Εμφάνισε _____ Αλλιώς Εμφάνισε _____ Τέλος_Αν Τέλος_Επανάληψης Τέλος Συμπλήρωση_κενών 24. Να σχηματίσετε τον πίνακα τιμών και το διάγραμμα ροής του παρακάτω αλγορίθμου. Αλγόριθμος Άσκηση α ← 0 Όσο (α <= 22) επανάλαβε Για i από 1 μέχρι 3 α ← α + i Τέλος_Επανάληψης α ← α + 5 Εκτύπωσε α Τέλος_Επανάληψης Εκτύπωσε α Τέλος Άσκηση

Page 7: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 7 ~ forum: http://ormimath1.comule.com

Απαντήσεις

Αλγόριθμος Ασκ1 Αρχή_επανάληψης Διάβασε Ν Μέχρις_ότου Ν ≥ 0 Παραγοντικό ← 1 Αν Ν > 1 τότε Για i από 1 μέχρι Ν Παραγοντικό ← Παραγοντικό*i Τέλος_επανάληψης Τέλος_αν Εμφάνισε Παραγοντικό Τέλος Ασκ1

Αλγόριθμος Ασκ2 στ ← 0 αρ ← 0 max ← -1 Για αθλητή από 1 μέχρι 18 Διάβασε τέρματα στ ← στ + τέρματα Αν τέρματα > 10 τότε αρ ← αρ + 1 Τέλος_αν Αν τέρματα > max τότε max ← τέρματα Τέλος_αν Τέλος_επανάληψης Εμφάνισε "Tο άθροισµα των τερµάτων είναι: ", στ Μ_Ο ← στ/18 Εμφάνισε "Ο µέσος όρος των τερµάτων είναι: ", Μ_Ο Εμφάνισε "Tο πλήθος των ποδοσφαιριστών που &πέτυχαν περισσότερα από 10 τέρµατα &είναι:", αρ Εμφάνισε "τα τέρµατα που πέτυχε ο πρώτος σκόρερ είναι: ", max Τέλος Ασκ2

Αλγόριθμος Ασκ3 Αρχή_επανάληψης Διάβασε Ν Μέχρις_ότου Ν > 0 Αν Ν mod 2 = 0 τότε S ← 0 Για i από 1 μέχρι Ν S ← S + 2^i Τέλος_επανάληψης αλλιώς S ← 1 Για i από 1 μέχρι Ν S ← S + 3^i/(2*i) Τέλος_επανάληψης Τέλος_αν Εμφάνισε S Τέλος Ασκ3

Αλγόριθμος Ασκ4 Για x από -20 μέχρι 20 Για y από -20 μέχρι 20 εξίσωση ← 2*x + 3*y Αν εξίσωση = 10 τότε Εμφάνισε " Λύση της εξίσωσης: χ=", x, "y=", y Τέλος_αν Τέλος_επανάληψης Τέλος_επανάληψης Τέλος Ασκ4

Αλγόριθμος Ασκ5 Για i από 10000 μέχρι 99999 Δεκαδες_Χιλιαδες ← i div 10000 βοηθ ← i mod 10000 Χιλιαδες ← βοηθ div 1000 βοηθ ← βοηθ mod 1000 Εκατονταδες ← βοηθ div 100 βοηθ ← βοηθ mod 100 Δεκαδες ← βοηθ div 10 Μοναδες ← βοηθ mod 10 Αν (Δεκαδες_Χιλιαδες = Μοναδες) και(Χιλιαδες = Δεκαδες) τότε Εκτύπωσε i Τέλος_αν Τέλος_επανάληψης Τέλος Ασκ5

ΠΡΟΓΡΑΜΜΑ Ασκ6 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: αριθμος, ψηφία !ΠΡΑΓΜΑΤΙΚΕΣ: !ΧΑΡΑΚΤΗΡΕΣ: !ΛΟΓΙΚΕΣ: ΑΡΧΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ 'Δώσε θετικό ακέραιο αριθμό : ' ΔΙΑΒΑΣΕ αριθμος ΜΕΧΡΙΣ_ΟΤΟΥ αριθμος > 0 ψηφία <- 0 ΟΣΟ αριθμος > 0 ΕΠΑΝΑΛΑΒΕ αριθμος <- αριθμος div 10 ψηφία <- ψηφία + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ "Το πλήθος των ψηφίων του αριθμού είναι: ", ψηφία ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Οθόνη εκτέλεσης: Δώσε θετικό ακέραιο αριθμό :1234 Το πλήθος των ψηφίων του αριθμού είναι: 4

Page 8: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 8 ~ forum: http://ormimath1.comule.com

ΑΡΧΗ

ΓΡΑΨΕ

'Δώσε θετικό ακέραιο αριθμό : '

ΔΙΑΒΑΣΕ

αριθμος

αριθμος > 0Ψ

ψηφία <-- 0

Α

αριθμος > 0

αριθμος <-- αριθμος div 10

Α

ψηφία <-- ψηφία + 1

ΓΡΑΨΕ

'Το πλήθος των ψηφίων του αριθμού είναι: ' , ψηφία

Ψ

ΤΕΛΟΣ

Page 9: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 9 ~ forum: http://ormimath1.comule.com

ΠΡΟΓΡΑΜΜΑ Ασκ7 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Αρ_αγώνων, πόντοι !ΠΡΑΓΜΑΤΙΚΕΣ: !ΧΑΡΑΚΤΗΡΕΣ: !ΛΟΓΙΚΕΣ: ΑΡΧΗ Αρ_αγώνων <- 0 ΔΙΑΒΑΣΕ πόντοι ΟΣΟ πόντοι>=0 ΚΑΙ πόντοι<=200 ΕΠΑΝΑΛΑΒΕ ΑΝ πόντοι >= 10 ΤΟΤΕ Αρ_αγώνων <- Αρ_αγώνων + 1 ΤΕΛΟΣ_ΑΝ ΔΙΑΒΑΣΕ πόντοι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Αρ_αγώνων ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ Ασκ8 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: φορ, επιβ, μοτ, Συν_οχημ ΧΑΡΑΚΤΗΡΕΣ: τύπος ΑΡΧΗ φορ <- 0 επιβ <- 0 μοτ <- 0 Συν_οχημ <- 0 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ 'Δώσε τον τύπο του οχήματος' ΔΙΑΒΑΣΕ τύπος ΜΕΧΡΙΣ_ΟΤΟΥ τύπος = 'Φ' Η τύπος = 'Ε' Η τύπος = 'Μ' Η τύπος = 'τέλος' ΟΣΟ τύπος <> 'τέλος' ΚΑΙ Συν_οχημ < 450 ΕΠΑΝΑΛΑΒΕ ΑΝ τύπος = 'Φ' ΤΟΤΕ φορ <- φορ + 1 ΑΛΛΙΩΣ_ΑΝ τύπος = 'Ε' ΤΟΤΕ επιβ <- επιβ + 1 ΑΛΛΙΩΣ μοτ <- μοτ + 1 ΤΕΛΟΣ_ΑΝ Συν_οχημ <- Συν_οχημ + 1 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ 'Δώσε τον τύπο του οχήματος' ΔΙΑΒΑΣΕ τύπος ΜΕΧΡΙΣ_ΟΤΟΥ τύπος = 'Φ' Η τύπος = 'Ε' Η τύπος = 'Μ' Η τύπος = 'τέλος' ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ 'Σύνολο φορτηγών: ', φορ ΓΡΑΨΕ 'Σύνολο Ι.Χ: ', επιβ ΓΡΑΨΕ 'Σύνολο μοτοσικλετών: ', μοτ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Αλγόριθμος Ασκ9 Αρ_ικα ← 0 S_ημερ ← 0 max ← -1 Αρχή_επανάληψης Διάβασε πλήθος Μέχρις_ότου (πλήθος ≥ 10)και(πλήθος ≤ 500) Για ασθενή από 1 μέχρι πλήθος Διάβασε ημερ_νοσ, ασφάλ Αν ασφάλ = 'Ι' τότε Αρ_ικα ← Αρ_ικα + 1 Τέλος_αν S_ημερ ← S_ημερ + ημερ_νοσ Αν ημερ_νοσ > max τότε max ← ημερ_νοσ Τέλος_αν Τέλος_επανάληψης Εμφάνισε 'Ο συνολικός αριθμός ασφαλισμένων στο ΙΚΑ είναι:', Αρ_ικα Σποσό ← S_ημερ*93 Εμφάνισε 'Το ποσό κόστισαν οι ασθενείς είναι:', Σποσό ΜΟ ← S_ημερ/πλήθος Εμφάνισε 'O μέσος όρος ημερών νοσηλείας είναι: ', S_ημερ Εμφάνισε 'Ο μέγιστος αριθμός ημερών νοσηλείας είναι: ', max Τέλος Ασκ9

Αλγόριθμος Ασκ10 Καθ ← 50 Συν_καθισματα ← Καθ Για σειρά από 1 μέχρι 15 Αυξηση ← Α_Μ(Καθ*10/100) Καθ ← Καθ + Αυξηση Συν_καθισματα ← Συν_καθισματα + Καθ Τέλος_επανάληψης Εμφάνισε 'Τα καθίσματα της τελευταίας σειράς είναι: ',Καθ Εμφάνισε 'Η χωρητικότητα του θεάτρου είναι: ', Συν_καθισματα Τέλος Ασκ10

Οθόνη εκτέλεσης: Τα καθίσματα της τελευταίας σειράς είναι: 196 Η χωρητικότητα του θεάτρου είναι: 1725

Page 10: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 10 ~ forum: http://ormimath1.comule.com

Αλγόριθμος Ασκ11 Σποσο ← 0 Σκαθ ← 0 Σειρα ← 6 Κοστος ← Σειρα*45 Όσο Σποσο + Κοστος ≤ 25000 επανάλαβε Σποσο ← Σποσο + Κοστος Σκαθ ← Σκαθ + Σειρα Σειρα ← Σειρα + 6 Κοστος ← Σειρα*45 Τέλος_επανάληψης Εμφάνισε 'Ο αριθμός των καθισμάτων που μπορούν να τοποθετηθουν είναι: ', Σκαθ Εμφάνισε 'Τα χρήματα που θα περισσέψουν είναι: ', 25000 - Σποσο Τέλος Ασκ11

Οθόνη εκτέλεσης: Ο αριθμός των καθισμάτων που μπορούν να τοποθετηθούν είναι: 546 Τα χρήματα που θα περισσέψουν είναι: 430

Αλγόριθμος Ασκ12 ΣΑ ← 0 ΣΒ ← 0 ΣΓ ← 0 ΣΔ ← 0 Για τμήμα από 1 μέχρι 1500 Διάβασε ΨήφουςΑ, ΨήφουςΒ, ΨήφουςΓ, ΨήφουςΔ ΣΑ ← ΣΑ + ΨήφουςΑ ΣΒ ← ΣΒ + ΨήφουςΒ ΣΓ ← ΣΓ + ΨήφουςΓ ΣΔ ← ΣΔ + ΨήφουςΔ Τέλος_επανάληψης ΠοσΑ ← (ΣΑ/(ΣΑ + ΣΒ + ΣΓ + ΣΔ))*100 ΠοσΒ ← (ΣΒ/(ΣΑ + ΣΒ + ΣΓ + ΣΔ))*100 ΠοσΓ ← (ΣΓ/(ΣΑ + ΣΒ + ΣΓ + ΣΔ))*100 ΠοσΔ ← (ΣΔ/(ΣΑ + ΣΒ + ΣΓ + ΣΔ))*100 Εμφάνισε 'Το κόμμα Α πήρε: ',ΣΑ,' ψήφους, και ποσοστό :', ΠοσΑ, '%' Εμφάνισε 'Το κόμμα Β πήρε: ',ΣΒ,' ψήφους, και ποσοστό :', ΠοσΒ, '%' Εμφάνισε 'Το κόμμα Γ πήρε: ',ΣΓ,' ψήφους, και ποσοστό :', ΠοσΓ, '%' Εμφάνισε 'Το κόμμα Δ πήρε: ',ΣΔ,' ψήφους, και ποσοστό :', ΠοσΔ, '%' Τέλος Ασκ12

Αλγόριθμος Ασκ13 maxa ← 0 !Αρχικοποίηση εκτός ορίων maxγ ← 0 Σβαθ ← 0 Αρ_αριστ ← 0 Αρ_δ ← 0 Για μαθητή από 1 μέχρι 150 Διάβασε Όνομα Αρχή_επανάληψης Διάβασε φύλο Μέχρις_ότου φύλο = 'Α' ή φύλο = 'Γ' Αρχή_επανάληψης Διάβασε βαθμός Μέχρις_ότου βαθμός ≥ 1 και βαθμός ≤ 20 Αν φύλο = 'Α' τότε Αν βαθμός > maxa τότε maxa ← βαθμός posa ← Όνομα Τέλος_αν αλλιώς Αν βαθμός > maxγ τότε maxγ ← βαθμός posγ ← Όνομα Τέλος_αν Τέλος_αν Αν βαθμός ≥ 18.5 τότε Σβαθ ← Σβαθ + βαθμός Αρ_αριστ ← Αρ_αριστ + 1 Τέλος_αν Αν βαθμός < 10 τότε Αρ_δ ← Αρ_δ + 1 Τέλος_αν Τέλος_επανάληψης Εμφάνισε 'Ο μαθητής με την μεγαλύτερο βαθμό είναι ο:', posa Εμφάνισε 'H μαθήτρια με την μεγαλύτερο βαθμό είναι η:', posγ Αν Αρ_αριστ ≠ 0 τότε Μ_Ο ← Σβαθ/Αρ_αριστ Εμφάνισε 'Ο μέσος όρος των άριστων είναι:', Μ_Ο Τέλος_αν Εμφάνισε 'Βαθμό κάτω από 10 είχαν: ', Αρ_δ, 'μαθητές' Τέλος Ασκ13

Page 11: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 11 ~ forum: http://ormimath1.comule.com

Αλγόριθμος Ασκ14 Σχρ ← 0 Αρb ← 0 Xrb ← 0 ΑρD ← 0 XrD ← 0 Για πελάτη από 1 μέχρι 20 Διάβασε Όνομα Αρχή_επανάληψης Διάβασε Κωδικός Μέχρις_ότου Κωδικός = 1 ή Κωδικός = 2 Αρχή_επανάληψης Διάβασε ημέρες Μέχρις_ότου ημέρες > 0 Αν Κωδικός = 1 τότε Αν ημέρες ≤ 4 τότε Χρέωση ← 3.5 αλλιώς Χρέωση ← 3.5 + 1.8*(ημέρες - 4) Τέλος_αν Αρb ← Αρb + 1 Xrb ← Xrb + Χρέωση αλλιώς Αν ημέρες ≤ 3 τότε Χρέωση ← 2.5 αλλιώς Χρέωση ← 2.5 + 1.5*(ημέρες - 3) Τέλος_αν ΑρD ← ΑρD + 1 XrD ← XrD + Χρέωση Τέλος_αν Εμφάνισε 'Ποσό πληρωμής:', Χρέωση Σχρ ← Σχρ + Χρέωση Τέλος_επανάληψης Εμφάνισε 'Η συνολική χρέωση είναι:', Σχρ Αν Αρb ≠ 0 τότε ΜΟBlu ← Xrb/Αρb Εμφάνισε 'Ο μέσος όρος χρέωσης των Blu-ray είναι:', ΜΟBlu Τέλος_αν Αν ΑρD ≠ 0 τότε ΜΟDvd ← XrD/ΑρD Εμφάνισε 'Ο μέσος όρος χρέωσης των DVD είναι:', ΜΟDvd Τέλος_αν Τέλος Ασκ14

Αλγόριθμος Ασκ15 Πάγιο ← 3000 Κόστος ← Πάγιο Αύξηση ← 0.80 Για μέτρα από 101 μέχρι 550 Κόστος ← Κόστος + Αύξηση Αύξηση ← Αύξηση + Αύξηση*(1.25/100) Τέλος_επανάληψης Εμφάνισε Κόστος Διάβασε Ποσό μέτρα ← 0 Αν Ποσό = 3000 τότε μέτρα ← 100 αλλιώς_αν Ποσό > 3000 τότε Σκόστος ← 3000 Αύξηση ← 0.80 μέτρα ← 100 Όσο Σκόστος + Αύξηση ≤ Ποσό και μέτρα < 550 επανάλαβε μέτρα ← μέτρα + 1 Αύξηση ← Αύξηση + Αύξηση*(1.25/100) Σκόστος ← Σκόστος + Αύξηση Τέλος_επανάληψης Τέλος_αν Εμφάνισε 'Με το διάθέσιμο ποσό των:',Ποσό,'€ η γεώτρηση μπορεί να φτάσει σε: ', μέτρα,' μέτρα βάθος' Τέλος ασκ15

Αλγόριθμος Ασκ16 Σβάρος ← 0 Συν_έσοδα ← 0 max ← -1 φ ← 0 Διάβασε επ_βάρος Διάβασε βάρος Όσο Σβάρος + βάρος ≤ επ_βάρος επανάλαβε Σβάρος ← Σβάρος + βάρος Διάβασε τύπος Αν τύπος = 'Φ' τότε χρέωση ← 5.50 φ ← φ + 1 αλλιώς φ ← 0 Τέλος_αν Αν φ > max τότε max ← φ Τέλος_αν Αν τύπος = 'Α' τότε χρέωση ← 3.40 αλλιώς_αν τύπος = 'Μ' τότε χρέωση ← 1.25 Τέλος_αν Συν_έσοδα ← Συν_έσοδα + χρέωση Διάβασε βάρος Τέλος_επανάληψης Εκτύπωσε 'Τα συνολικά έσοδα είναι:', Συν_έσοδα Εκτύπωσε 'Ο μέγιστος αριθμός συνεχόμενων φορτηγών είναι:', max Τέλος Ασκ16

Page 12: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 12 ~ forum: http://ormimath1.comule.com

Αλγόριθμος Ασκ17 i ← 1 s ← 0 Όσο i ≤ 5 επανάλαβε s ← s + (-1)^i*i^2 i ← i + 1 Τέλος_επανάληψης Εμφάνισε s Τέλος Ασκ17

Άσκηση 18

Άσκηση 19)

α <-- 2 Για β από 3 μέχρι 11 με_βήμα 2 Εμφάνισε β Τέλος_επανάληψης α <-- 2 β <-- 3 Όσο β<=11 επανάλαβε Εμφάνισε β β <-- β+2 Τέλος_επανάληψης

Page 13: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 13 ~ forum: http://ormimath1.comule.com

Άσκηση 20)

Αλγόριθμος Ασκ20 Αρχή_επανάληψης Διάβασε Πλήθος Μέχρις_ότου Πλήθος > 0 άθροισμα ← 0 i ← 0 Όσο i ≤ Πλήθος επανάλαβε Διάβασε αριθμός άθροισμα ← άθροισμα + αριθμός i ← i + 1 Τέλος_επανάληψης Εμφάνισε άθροισμα Τέλος Ασκ20

Θα εμφανιστεί το άθροισμα (πλήθος +1) αριθμών, που δώσαμε.

Άσκηση 21)

Πίνακας Τιμών :

Θα εκτυπωθεί 3 , 21 , 75

Page 14: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 14 ~ forum: http://ormimath1.comule.com

Άσκηση 22)

Θα εκτυπωθεί 9,5,24,7,48,9,80,11. Διάγραμμα Ροής

Άσκηση 23) Αλγόριθμος Συμπλήρωση_κενών Για i από 1 μέχρι 7 Αν i mod 2 = 0 τότε Εμφάνισε i Αλλιώς Εμφάνισε - i Τέλος_Αν Τέλος_Επανάληψης Τέλος Συμπλήρωση_κενών Άσκηση 24)

Page 15: 3 Συμπληρωματικές Ασκήσεις στη Δομή Επανάληψης_απαντήσεις

ΕΚΠΑΙΔΕΥΤΙΚΟΣ ΟΡΓΑΝΙΣΜΟΣ

OPMH κοντά στο μαθητή!

ΚΕΝΤΡΙΚΗ ΔΙΕΥΘΥΝΣΗ: Γούναρη 35 & Κανακάρη, Τηλ: 2610 - 279 - 873, 2610 - 622-855 site:www.ORMH.gr fb: http://www.facebook.com/EkpaideutikosOrganismosOrmh

email: [email protected] ~ 15 ~ forum: http://ormimath1.comule.com

Πίνακας Τιμών

Θα εκτυπωθεί 11,22,33,33.

1

α i Εκτυπωτής

1 1

3 2

6 3

11 4 11

12 1

14 2

17 3

22 4 22

23 1

25 2

28 3

33 4 33

33