Petit Guide Excel

Embed Size (px)

DESCRIPTION

PETIT GUIDE EXCEL

Text of Petit Guide Excel

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    1

    PETIT GUIDE EXCEL

    Sommaire :

    1) La fonction =SOMME()

    Pour additionner entre elles plusieurs cellules contigus.

    2) La formule =SOMME.SI()

    Cette fonction vous permet d'additionner plusieurs cellules en fonction d'un critre dtermin.

    3) La formule =SOMME.SI.ENS()

    Cette formule permet d'additionner plusieurs cellules en fonction de plusieurs critres.

    4) La formule =SOMMEPROD()

    Ralisation d'oprations conditionnelles comptant et additionnant en utilisant des conditions multiples.

    5) La fonction =MOYENNE()

    Pour obtenir la moyenne de plusieurs cellules contigus.

    6) La formule =ARRONDI()

    Pour viter que le rsultat dune division ou dune multiplication soit un nombre comportant plusieurs dcimales.

    7) La formule =RECHERCHEV()

    Pour chercher une valeur dans la premire colonne dun tableau puis afficher le contenu de la cellule qui se situe sur la mme ligne que la valeur recherche.

    8) La formule INDEX() et EQUIV()

    La fonction INDEX utilise avec la fonction EQUIV permet la recherche de valeur dans une matrice.

    9) Choix des rfrences de cellules

    Rfrence Absolue, relative, mixte, nomme

    10) Nota Bene

    N'oubliez pas que vous pouvez combiner ces fonctions entre elles.

    11) Cration dun graphique

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    2

    1) La fonction =SOMME()

    Pour additionner entre elles plusieurs cellules contigus, on peut utiliser la fonction SOMME dEXCEL.

    Ecrire dans la cellule o doit apparatre le rsultat : =somme( Slectionner ensuite la souris la plage de cellules additionner. Valider avec la touche Entre

    La fonction renvoie laddition des sommes slectionnes.

    Exemple :

    En A5 on crit la formule suivante :

    =SOMME(A1:A4)

    Le rsultat donne : 31

    2) La formule =SOMME.SI() Cette fonction vous permet d'additionner plusieurs cellules en fonction d'un critre dtermin.

    Voici sa syntaxe :

    =SOMME.SI(plage;critre;somme_plage)

    plage est la plage de cellule contenant le critre retenir

    critre est LE critre retenir (chiffre ou texte)

    somme_plage est la plage de cellule o se trouvent les nombres additionner.

    Exemple : Dans la colonne A on a crit des nombres. En colonne B, on a indiqu "garon" ou "fille". On voudrait obtenir le total des nombres de la colonne A auxquels correspondent le mot "fille" en colonne B.

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    3

    En A7 on crit la formule suivante :

    =SOMME.SI(B1:B6;"fille";A1:A6)

    Le rsultat donne : 66

    3) La formule =SOMME.SI.ENS()

    Cette formule permet d'additionner plusieurs cellules en fonction de plusieurs critres.

    Voici sa syntaxe :

    =SOMME.SI.ENS(Plage_somme ;Plage_critres1;Critres1;[plage_critres2;critres2];.)

    Exemple :

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    4

    Ici :

    Plage_somme, la plage de cellule contenant les montant additionner, (dans la formule D:D),

    Premire page de critres ; la colonne du service, la colonne C (dans la formule C:C),

    Premier critre, le service saisi en cellule G1,

    Deuxime plage de critres, la colonne du sexe, la colonne B (dans la formule B:B), Deuxime critre, le sexe saisie en cellule F2,

    4) La formule =SOMMEPROD()

    Ralisation d'oprations conditionnelles comptant et additionnant en utilisant des conditions multiples

    Les formules permettant de calculer le nombre de valeurs ou les sommes sont fondes sur deux conditions ou plus.

    La fonction que nous allons utiliser est SOMMEPROD ; celle-ci appartient la catgorie Math & Trigo.

    Exemple : Compter le nombre de mois o un commercial fait une vente. Le tableau de dpart pourrait se prsenter sous cette forme :

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    5

    Exemple 1 : Compter le nombre des ventes faites par Jules sur le mois de fvrier.

    C'est une formule conditionnelle qui emploie deux conditions.

    = SOMMEPROD((A2:A13="Jules")*(B2:B13="Fvrier"))

    Rsultat de formule: 2

    Exemple 2 : Compter les mois o les ventes sont plus grandes qu'une quantit spcifique

    Vous pouvez employer une formule semblable celle ci-dessus pour travailler avec des donnes numriques. Cette formule renvoie le nombre de lignes pour lesquelles le mois est gal janvier et le montant est suprieur 200.

    = SOMMEPROD((B2:B13="Janvier")*(C2:C13>200))

    Rsultat de formule: 5

    Exemple 3 : Compter le nombre de ventes comprises entre certaines valeurs spcifiques

    Cette formule compte le nombre de fois o les ventes sont comprises entre 200 et 500. La formule emploie deux conditions : la quantit suprieure ou gale 200, et la quantit infrieure ou gale 500.

    =SOMMEPROD((C2:C13>=200)*(C2:C13500))

    Rsultat de formule: 1

    Exemple 5 : Totaliser les ventes d'un commercial pour un mois donn

    La formule calcule la somme des ventes base sur deux conditions : quand le commercial est Jules et le mois est fvrier.

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    6

    =SOMMEPROD((A2:A13="Jules")*(B2:B13="Fvrier")*(C2:C13))

    Rsultat de formule: 1150

    Exemple 6 : Totaliser les ventes combines pour deux commerciaux

    La formule ci-dessous renvoie la somme des ventes pour Jules et Pascal. Cette formule emploie un argument simple et se compose de trois expressions.

    =SOMMEPROD(((A2:A13="Jules")+(A2:A13="Pascal"))*(C2:C13))

    Rsultat de formule: 2585

    Attention : les deux premiers arguments ne sont pas multiplis comme dans les exemples prcdents. Dans la mesure o nous ralisons un test logique " OU ", ils sont additionns. Addition de deux rsultats logiques de valeur 1 quand l'une ou l'autre des expressions est VRAIE.

    5) La fonction =MOYENNE()

    Pour obtenir la moyenne de plusieurs cellules contigus, on peut utiliser la fonction MOYENNE dEXCEL.

    Ecrire dans la cellule o doit apparatre le rsultat : =moyenne( Slectionner ensuite la souris la plage de cellules dsire Valider avec la touche Entre.

    La fonction renvoie la moyenne des sommes slectionnes

    Exemple : Dans la colonne A on a crit des nombres. On voudrait obtenir la moyenne des nombres de la colonne A.

    En A7 on crit la formule suivante :

    =MOYENNE(A1:A6)

    Le rsultat donne : 26

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    7

    6) La formule =ARRONDI()

    Le rsultat dune division ou dune multiplication peut donner un nombre comportant plusieurs dcimales. Dans le but de crer des formulaires destins des tiers (exemple facture) les nombres doivent, en principe, se prsenter avec simplement deux dcimales. On peut, bien entendu, utiliser le format des nombres. Mais Excel va conserver en mmoire le nombre initial avec plusieurs dcimales et lutilisera pour les calculs ultrieurs. Do des problmes daffichages.

    Exemple :

    Le rsultat du calcul : 2 divis par 3 donne le rsultat 0.666666666.....

    Si on additionne 0.66666666.... avec 0.6666666.... on obtient 1.33333333.....

    Avec un format des nombres deux dcimales, Excel propose un arrondi de prsentation qui donnera : 0.67 + 0.67 = 1.33. Evidemment, cet arrondi de prsentation nest pas satisfaisant. Il faut donc utiliser une formule dEXCEL, la formule ARRONDI()

    7) LA Formule =RECHERCHEV()

    La fonction RECHERCHEV cherche une valeur dans la premire colonne dun tableau puis elle affiche le contenu de la cellule qui se situe sur la mme ligne que la valeur recherche.

    Prenons un exemple :

    Nous voulons afficher le prnom dun candidat en fonction de son numro.

    Ici, nous cherchons le prnom du candidat 8.

    Dans Valeur_cherche , nous entrons E2 qui correspond 8. Dans Table_matrice , nous dfinissons une plage de cellule qui contient le tableau.

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    8

    Dans No_index_col , nous devons entrez le n de la colonne qui contient les donnes afficher (ici les prnoms). Le n de colonne est celui du tableau slectionn.

    Valeur_proche est facultatif, mais permet soit de chercher la valeur exacte de Valeur_cherche (en entrant : FAUX), soit de trouver la valeur la plus proche de Valeur_cherche (en entrant : VRAI ou en laissant vide).

    On obtient finalement le prnom de la candidate 8.

    Maintenant, il ne reste plus qu modifier E2 pour trouver un autre prnom.

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    9

    8) Les formules INDEX() et EQUIV()

    La fonction INDEX utilise avec la fonction EQUIV permet la recherche de valeur dans une matrice.

    Prenons un exemple :

    Nous souhaitons pouvoir trouver lge et/ou la ville en fonction du prnom (peut tre appliqu galement en fonction de lge ou de la ville).

    Voici la formule :

    =INDEX(C3:E12;EQUIV(H4;C3:C12;0);I6)

    C3:E12 : matrice de recherche H4 : valeur recherche (ici le prnom) C3:C12 : plage de cellule dans laquelle H4 sera recherche (ici les prnoms) 0 : recherche la valeur exacte (1 : valeur suprieure / -1 : valeur infrieure) I6 : n de la colonne contenant les valeurs afficher (ici les villes)

    En modifiant I6 on obtient :

  • Petit Guide Excel Stphane ROUBIEU et Guillaume HARENT

    10

    Remarque : Dans cet exemple, nous avons utilis la syntaxe suivante : =INDEX(matrice;EQUIV(valeur_cherche;matrice;0);no_colonne) Celle-ci est galement utilisable (dans cette version, le rsultat renvoy par la fonction EQUIV sera le n