Redistribute Giữa ISIS Và OSPF

  • View
    213

  • Download
    0

Embed Size (px)

DESCRIPTION

Redistribute Gia ISIS V OSPF

Transcript

Redistribute gia ISIS v OSPF

Redistribute gia ISIS v OSPF

Tc gi: Nguyn Th Bng Tm

Trong bi ny s thc hin redistribute gia hai giao thc classless l OSPF v ISIS vi nhau .

Mc tiu bi lm :

Thc hin multiple redistribute points (redistribute ti nhiu im )

Ch ra vn gp phi khi redistribute v cch gii quyt vn .

T mt router ping thy tt c cc a ch trong mng .

M hnh mng nh sau : router R3 v R4 s chy giao thc OSPF , R5 chy giao thc ISIS. Router R4 v R1 s l cc router thc hin redistribute .

a ch trn cc interface ca cc router :

Router

Interface

a ch

Router R1

E0/0

S0/0

172.16.1.1/24

172.16.2.2 /30

Router R2

S0/0

E0/0

172.16.2.1/30

192.168.4.2/24

Router R3

E0/0

S0/0

192.168.4.1/24

192.168.1.1/24

Router R4

S0/1

S0/0

192.168.1.2/24

192.168.2.1/30

Router R5

S0/0

E0/0

Loopback 0

192.168.2.2/30

172.16.1.2/24

10.1.1.1/24

Cu hnh ban u :

R1

!

hostname R1

!

enable password cisco

!

interface Ethernet0/0

ip address 172.16.1.1 255.255.255.0

!

interface Serial0/0

ip address 172.16.2.2 255.255.255.252

!

end

R2

!

hostname R2

!

interface Ethernet0/0

ip address 192.168.4.2 255.255.255.0

!

interface Serial0/0

ip address 172.16.2.1 255.255.255.252

clockrate 64000

!

ip classless

!

end

R3

!

hostname R3

!

interface Ethernet0/0

ip address 192.168.4.1 255.255.255.0

half-duplex

!

interface Serial0/0

ip address 192.168.1.1 255.255.255.0

no fair-queue

!

end

R4

!

hostname R4

!

interface Ethernet0/0

ip address 192.168.100.1 255.255.255.0

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.0

clockrate 64000

no fair-queue

!

interface Serial0/1

ip address 192.168.1.2 255.255.255.0

clockrate 64000

!

ip http server

ip classless

!

end

R5

!

hostname R5

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/0

ip address 172.16.1.2 255.255.255.0

no ip directed-broadcast

!

interface Serial0/0

ip address 192.168.2.2 255.255.255.252

!

ip classless

end

Cu hnh ban u cho cc router :

R1

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#line console 0

R1(config-line)#password cisco

R1(config-line)#login

R1(config)#line vty 0 4

R1(config-line)#password cisco

R1(config-line)#login

R1(config-line)#exit

R1(config)#enable password cisco

R1(config)#interface s0/0

R1(config-if)#ip address 172.16.2.2 255.255.255.252

R1(config-if)#clock rate 64000

R1(config-if)#no shutdown

R1(config-if)#int e0/0

R1(config-if)#ip address 172.16.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#

cu hnh cho router R2 :

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#line console 0

R2(config-line)#password cisco

R2(config-line)#line vty 0 4

R2(config-line)#no login

R2(config-line)#exit

R2(config)#interface e0/0

R2(config-if)#ip address 192.168.4.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#interface s0/0

R2(config-if)#ip address 172.16.2.1 255.255.255.252

R2(config-if)#clock rate 64000

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#^Z

R2#

cu hnh cho router R3 :

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R3

R3(config)#line console 0

R3(config-line)#password cisco

R3(config-line)#line vty 0 4

R3(config-line)#no login

R3(config-line)#exit

R3(config)#interface s0/0

R3(config-if)#ip address 192.168.1.1 255.255.255.0

R3(config-if)#clock rate 64000

R3(config-if)#no shutdown

R3(config-if)#interface e0/0

R3(config-if)#ip address 192.168.4.1 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)#exit

R3(config)#^Z

R3#

cu hnh cho router R4 :

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R4

R4(config)#line console 0

R4(config-line)#password cisco

R4(config-line)#line vty 0 4

R4(config-line)#no login

R4(config-line)#exit

R4(config)#interface s0/1

R4(config-if)#ip address 192.168.1.2 255.255.255.0

R4(config-if)#clock rate 64000

R4(config-if)#no shutdown

R4(config-if)#interface s0/0

R4(config-if)#ip address 192.168.2.1 255.255.255.252

R4(config-if)#clock rate 64000

R4(config-if)#no shutdown

R4(config-if)#exit

cu hnh cho router R5 :

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R5

R5(config)#line console 0

R5(config-line)#password cisco

R5(config-line)#line vty 0 4

R5(config-line)#no login

R5(config-line)#exit

R5(config)#interface s0/0

R5(config-if)#ip address 192.168.2.2 255.255.255.252

R5(config-if)#clock rate 64000

R5(config-if)#no shutdown

R5(config-if)#interface e0/0

R5(config-if)#ip address 172.16.1.2 255.255.255.0

R5(config-if)#no shutdown

R5(config-if)#interface loopback 0

R5(config-if)#ip address 10.1.1.1 255.255.255.0

R5(config-if)#^Z

R5#

kim tra bng nh tuyn :

R1#show ip route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.16.1.0/24 is directly connected, Ethernet0/0

C 172.16.2.0/30 is directly connected, Serial0/0

R2#show ip route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets

C 172.16.2.0 is directly connected, Serial0/0

C 192.168.4.0/24 is directly connected, Ethernet0/0

R3#show ip route

Gateway of last resort is not set

C 192.168.4.0/24 is directly connected, Ethernet0/0

C 192.168.1.0/24 is directly connected, Serial0/0

R4#show ip route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Serial0/1

192.168.2.0/30 is subnetted, 1 subnets

C 192.168.2.0/30 is directly connected, Serial0/0

R5#show ip route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.1.0 is directly connected, Ethernet0/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Loopback0

192.168.2.0/30 is subnetted, 1 subnets

C 192.168.2.0 is directly connected, Serial0/0

Cu hnh nh tuyn cho cc router .Router R2,R3, interface s0/0 ca R1 v interface s0/1 ca R4 chy OSPF process 1 ,cn li l chy ISIS .

Ta bit cu hnh ISIS i hi cn phi c a ch NET ,mi system-ID i din cho mi node, ta c th gn n mt cch ty nhng m bo system-ID l duy nht ca mi router trong mt area ta s s dng a ch Mac .

Ta kim tra a ch Mac ca thit b bng cch show arp hoc show interface .

R1#show arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 172.16.1.1 - 0004.c052.7ce0 ARPA Ethernet0/0

R4#show interface e0/0

Ethernet0/0 is administratively down, line protocol is down

Hardware is AmdP2, address is 0002.4b79.9ca0 (bia 0002.4b79.9ca0)

Internet address is 192.168.100.1/24

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 252/255, txload 1/255, rxload 1/255

R5#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 172.16.1.2 - 00d0.ba1a.f080 ARPA Ethernet0/0

Cu hnh nh sau :

R1(config)#router ospf 1

R1(config-router)#network 172.16.2.0 0.0.0.3 area 0

R1(config-router)#exit

R1(config)#clns routing

R1(config)#router isis

R1(config-router)#net 01.0001.0004.c052.7ce0.00

R1(config-router)#exit

R1(config)#interface e0/0

R1(config-if)#ip router isis

R1(config-if)#^Z

R1#

R2(config)#router ospf 1

R2(config-router)#network 192.168.4.0 0.0.0.255 area 0

R2(config-router)#network 172.16.2.0 0.0.0.3 area 0

R2(config-router)#exit

R2(config)#^Z

R3(config)#router ospf 1

R3(config-router)#network 192.168.4.0 0.0.0.255 area 0

R3(config-router)#network 192.168.1.0 0.0.0.255 area 0

R3(config-router)#exit

R3(config)#^Z

R4(config)#router ospf 1

R4(config-router)#network 192.168.1.0 0.0.0.255 area 0

R4(config-router)#exit

R4(config)#clns rout